Did I not ovulate this cycle???

The Big O! Everything OVULATION related goes here, including OPK pics, questions about ovulation, etc.

Moderators: unaffected, JessM, southernbelle, maddy

Did I not ovulate this cycle???

Postby MRS.K80 » Sun Aug 20, 2017 4:07 pm

So, I normally ovulate, on average, around cycle day 14. This cycle, I can not figure it out... no ewcm, no big temp shift. In fact, I have not had a big temp shift since I O'd last cycle! My temp never dropped before, during, or after af! All my temps this cycle are high post O temps. Maybe its an anovulatory cycle?

My Ovulation Chart
TTC#1
Started Feb 2017

Im 29yo
DH 28yo
Stepson 8yo (would love a sibling!!!)
MRS.K80
BabyDuster
BabyDuster
 
Posts: 80
Joined: Fri May 19, 2017 6:29 am

Re: Did I not ovulate this cycle???

Postby Danaa » Mon Aug 21, 2017 1:57 pm

I think you may have O on cd24,if your next temp is still high you might get CH on cd24,if it won't,try removing ur cd22temp and see what happens.
Good luck!
Image
My Ovulation Chart
.
Me 29
DH 31
After 3 years in which we tried everything we are doing IVF in Greece with Iakentro Athens.
Short Protocol with Bemfola and Cetrotide
19mature eggs and we have 9 day5 blasto.
FET#1 ended in a loss around 5 weeks
FET#2 ended in a loss at 22w due to IC,my boys will be forever in my heart .
FET#3 ?
User avatar
Danaa
Girlfriend
Girlfriend
 
Posts: 9129
Joined: Wed Nov 12, 2014 5:54 am

Re: Did I not ovulate this cycle???

Postby Danaa » Mon Aug 21, 2017 1:58 pm

Okay try adding a new high temp in advance and see if you get CH.
Image
My Ovulation Chart
.
Me 29
DH 31
After 3 years in which we tried everything we are doing IVF in Greece with Iakentro Athens.
Short Protocol with Bemfola and Cetrotide
19mature eggs and we have 9 day5 blasto.
FET#1 ended in a loss around 5 weeks
FET#2 ended in a loss at 22w due to IC,my boys will be forever in my heart .
FET#3 ?
User avatar
Danaa
Girlfriend
Girlfriend
 
Posts: 9129
Joined: Wed Nov 12, 2014 5:54 am

Re: Did I not ovulate this cycle???

Postby MRS.K80 » Wed Aug 23, 2017 8:47 am

So I did get CHs. But then when I added todays temps, ff removed them and said ovulation not detected.

Today was 97.9
TTC#1
Started Feb 2017

Im 29yo
DH 28yo
Stepson 8yo (would love a sibling!!!)
MRS.K80
BabyDuster
BabyDuster
 
Posts: 80
Joined: Fri May 19, 2017 6:29 am

Re: Did I not ovulate this cycle???

Postby MRS.K80 » Wed Aug 23, 2017 8:48 am

FF originally said I O'd on cd20
TTC#1
Started Feb 2017

Im 29yo
DH 28yo
Stepson 8yo (would love a sibling!!!)
MRS.K80
BabyDuster
BabyDuster
 
Posts: 80
Joined: Fri May 19, 2017 6:29 am

Re: Did I not ovulate this cycle???

Postby Danaa » Wed Aug 23, 2017 10:03 am

I see ur cd27 temp wasn't taken at the same time as usual?try removing that and see what it shows.
Image
My Ovulation Chart
.
Me 29
DH 31
After 3 years in which we tried everything we are doing IVF in Greece with Iakentro Athens.
Short Protocol with Bemfola and Cetrotide
19mature eggs and we have 9 day5 blasto.
FET#1 ended in a loss around 5 weeks
FET#2 ended in a loss at 22w due to IC,my boys will be forever in my heart .
FET#3 ?
User avatar
Danaa
Girlfriend
Girlfriend
 
Posts: 9129
Joined: Wed Nov 12, 2014 5:54 am


Return to Ovulation