Page 1 of 1

I'm stumped.

PostPosted: Mon Oct 30, 2017 6:52 pm
by TeaPotts
Completely stumped. This is my first clomid round, 50mg CD3-7. Today is CD 14. I don't ovulate on my own (if I do, it's extremely sporadically). I had some on-and-off breast soreness and ovary twinges for a few days, one day of EWCM and 2ish days of watery, and then got a + opk (the first one EVER) on CD 11. Woke up CD 12 with a huge drop in temperature, and by the end of that day, I had no more symptoms and my CM had dried up. I felt so confident that it was O day, and was overjoyed! But then...my temp didn't shoot up! I'm getting a steady rise, but my temp is low compared to the temps before my suspected O day. Those pre-"O" temps are much higher than any of my past cycles, though. I thought maybe that has to do with Clomid...

I've continued monitoring my CM and taking opks; I'm still quite dry and and the opks are more negative than any opks I've ever taken, I think. I'm still wondering if it's possible that I O'd, even with such a weird chart.

Has anyone ever seen or experienced something like this before? Any insight?

Re: I'm stumped.

PostPosted: Tue Oct 31, 2017 7:19 am
by Danaa
According to your temperature you have not ovulated yet,as for the + opks it might be that ur body geared up to ovulation but it didn’t,keep taking opks and temping.
Good luck!

Re: I'm stumped.

PostPosted: Tue Oct 31, 2017 7:23 am
by TeaPotts
Thanks, Danaa! I got a huge spike this morning, but have gotten negative opks since that positive, so I'm curious to see what happens over the next couple of days!

Re: I'm stumped.

PostPosted: Sat Nov 11, 2017 8:32 am
by TeaPotts
Update...that was a false alarm, but I ended up Oing about a week later, on CD 20! Had a big dip this morning, and I'm trying not to get my hopes up too much... :)